Chromebook coding, joystick blocking run


#1

Good morning. Was using the online / studio app on a Samsung Chromebook to look into Blockly coding. Created what seemed to be an ok program, tried Run and nothing would happen on the robot. Tested all motors etc and everything checked out. Asked studio to sense the sensors. Again everything checked out. Finally by trial and error, we went thru the sensor/port settings in studio and clicked joystick to OFF and everything ran.

That’s the short version of everything we tried. Question is…is this a known issue ? I skimmed thru the documentation and could not see anything referencing this… Any insight and commentary welcome.


#2

Did you have the Vex IQ Controller on and properly linked or tethered to the “brain”?


#3

Yes. It really is odd. We had it all tethered. We did self tests. We made sure that the motor ports were correct. In STUDIO we asked the debugger / console to detect settings. Everything worked AOK. Even downloading the program worked, and the LCD would show the program name, but nothing ran.

So in studio we checked the motor settings again, also the drivetrain. Everything good.

Then i looked at all the other settings. Noticed that joystick had been detected as ON by the debugger. Checked it to OFF. Re downloaded and ran, and it worked.

Really wondering if we missed something obvious or this is a wrinkle.


#4

Does the Controller work on the Driver demo built into the “brain”? I believe that requires motors in ports 1 and 6 (or 7 and 12?).


#5

We didn’t . Once we discovered turning the JOYstick to OFF allowed us to run the programs as expected we declared SUCCESS and paused for the day.

Additionally, not only were we unable to run the program from the chromebook via USB, but until we had changed the Joystick setting to OFF we were unable to RUN the program on the brain itself. We could select it, click the check mark to run, but it would just sit there. It’s almost as if having the joystick mode ON was blocking the brain from doing anything else.

And yes we are on current firmware and we only downloaded the Studio / Connection apps / extensions to the Chromebook this morning so those were current as well.


#6

I would be interested if you could check that next time… It is a good self-test for Controller involved issues. The symptoms

are consistent with an unlinked Controller, perhaps the Controller is linked to another bot, or there is a tether cable or Controller hardware issue? Were the link lights flashing green ( I think that happens after you detach the tether cable, which links the Controller)?


#7

Yeah we’ll run some more tests. Today I was like done! But at least the kids then this afternoon were able to program the bot and have fun.


#8

Alright, played with it again this evening. Setup Chromebook from scratch and added simple DriveTrain forward program. Clicked Run and it ran.

Clicked the joystick setting on the debugger, added a joystick. Clicked Run and program went to VEX but does not appear to execute. Cleared joystick to NONE and clicked run and it ran successfully. This may be by design, but to a newcomer it was truly frustrating to not see an obvious reason why our VEX was obviously receiving the code, but not running it.53%20AM


#9

Does the Controller work on the Driver demo built into the “brain”?

Vex has two modes, Autonomous and Teleop, if a Controller is asked for by the program, the program will appear to start, but execute no code until the Controller/joystick is linked successfully.

In Teleop mode the “antennae” bars on the upper right of the brain’s LCD will cycle until linked, and when linked the green lights on both brain and Controller will blink.

In Autonomous, no bars…

If you “Run” the “Driver Control” built-in to the brain, it will ask you to “Connect Controller” if not linked. That is a built-in autonomous program.


#10

No bars showing. Just a strange message on Chromebook when we add a joystick. The program downloads, nothing happens, but the screen says (u3\x1): 26%20AM


#11

Let’s be clear, do you have a Controller linked to the brain?

Or perhaps, tethered with the blue cable?

And, do you have a radio in the slot in the brain?


#12

Looking at that now. The brain and the controller were tethered with radio. Right now i’m replicating all those conditions.


#13

“Tethered” is used to describe when cable is attached. Detaching the cable when successfully tethered (plug icon shows on upper right LCD) is what causes the radios to link.


#14

You hit the nail on the head. So when joystick is [ON] in the debugger / settings window, then if the controller is not connected to the brain in any way (tethered / radio) then the program gets sent to the brain but the brain sits there, and does nothing, EVEN though the program itself does not require the controller.

When the controller was actively connected, the program ran, even though no controller intervention was required by the program.


#15

Good. Yes, selecting the joystick in the configuration panel causes the program to send instructions to use the Controller. No other indication is given (unlike the Driver Control demo) but if no Controller, bot waits patiently…


#16

Yup. Patiently is one word for it. :slight_smile: All makes sense now and documenting it to help the robot club understand better what they need to do if they are looking to control the bot from the Chromebook alone.


#17

Similar situation can occur if sensors, motors attached to brain do not match those set in the config panel. RMS does a good job with the “Connect” and “Detect…” buttons, but sometimes you need to check. Also, turn off brain when connecting, disconnecting wires to it.

How old are they?


#18

I believe 1 year old. They were having issues getting it all working in class so my son offered to take it home for a weekend to help out. Hence our struggle! @ home we have the Mindstorms and the Boost etc so we’re fairly familiar with their nuances, but the VEX was a steeper learning curve, coupled with the issue that “well we are connected, we have this program, it says its transmitting, there it is on the block, but its not running…” issue we encountered.


#19

Oh. I meant the students.:blush:


#20

Ha! 4th Grade.

As a STEAM school they’ve made an investment in Chromebooks so getting all this working with Chromebooks is a huge step.

BTW thanks for all your help on this.