Computer refusing to do anything with VEX IQ Brain

Well first off let me just start by saying I am completely new to VEX. I just bought and built the VEX IQ Super Kit. The clawbot is working fine but when I build the autopilot bot the autopilot program does not appear. I have all of the required sensors connected. So I tried connecting the brain to my computer and it refuses to find drivers. I got all the programs on the VEX IQ page and they are working, but I get “board missing” in the browser program. When I install the VEX IQ firmware updater windows goes nuts in the background opening windows solutions to connecting usb devices. I’ve spent the past 3 hours looking through anything and everything I can think of with not luck figuring out my problem. I’ve read that just connecting the brain windows should find and download the driver but when I connect it windows starts searching but never finds anything. I am using windows 7 on a pc I built, I’ve checked and reinstalled all of the usb related drivers for my motherboard with no luck. I’m sure I sound hopeless here but if someone could please get back to me I’ll get any info you need and try any suggestions. Please tell me how to find any info you may need, just in case I don’t know. Thanks a bunch for any help!

Hi Dzzs,

The Autopilot program is not yet available in Robot Brain firmware version 1.07. Full support for the Autopilot program will be coming very soon.

The driver needed to for Windows to communicate with the Robot Brain is only available inside the VEX IQ Firmware Update Utility installer. You must run this installer before connecting the Robot Brain to your computer. The driver might not correctly install if VEX IQ devices are connected to the computer before or during the installation.

To correct these issues, please follow these instructions:

  1. Physically disconnect all VEX IQ devices from your computer
  2. Uninstall the previous versions of the VEX IQ Firmware Update Utility
  3. Download the latest (version 1.17) of the VEX IQ Firmware Update Utility. Launch the installer. Use Run as Administrator if your Windows user account is not an admin account.
  4. Follow the installation steps and leave all settings as default values. Ensure the Robot Brain is NOT connected during any of this process,
  5. About half way through the setup wizard, a single pop up window will appear that says “The next step will install the necessary drivers for your VEX products.” Click OK to install the VEX USB serial port driver. This is the ONLY popup window that appears during the installation wizard.
  6. When the installer finishes, you can now connect the Robot Brain to your computer and turn it on. Windows should automatically recognize the device as the VEX USB serial port, as indicated by a tiny popup message box in the lower right system tray.

This can be verified in the Device Manager (click Start, type in “Device Manager”, then launch the program with that name from the search results).

Under "Ports (COM & LPT), you should see “VEX USB serial port (COM20)” on your computer. Please note that depending on the computer, you may see a different COM port number. The specific COM port number does not matter as long as it is unique (no other devices on that same COM port).

If you can see “VEX USB serial port” listed here, your computer can now communicate with the Robot Brain.


  • Art

Thank you so much for the reply and helpful info. It turns out whatever drivers I had for my usb controller just were’t working for the step 5 you mentioned. Rather than getting the VEX drivers it went looking for something else it could never find. Your post helped me find that issue though so this fix is still thanks to your response. If it’s of any use to you my issue area was my “Etron USB 3.0 extensible host controller” and whatever default drivers/updates it came with. I just searched for a recently updated driver for it (18 days ago) and that solved my problem. Thanks again for the help. You saved my interest in VEX.