VEX IQ Connection and Robot Brain Issues


I am new to VEX IQ, and I am having some trouble with my computer recognizing the Robot Brain being plugged into my desktop in the VEX Coding Studio.
When I plug in the USB from the Robot Brain to my desktop, it is not recognizing it and saying “no devices found”. I have installed the VEX Utility Setup program and tried to update the Robot Brain, but this did not solve my problem. If I could get any troubleshooting tips for connecting the Robot Brain to the desktop using USB I would really appreciate it.

Another problem I am having with a separate Robot Brain is that the screen is stuck on the screen that is shown while updating. I have attached a picture. I have unplugged the battery and from my desktop, but the screen still shows up even after restarting it. Help with this issue is greatly appreciated as well.
Once again, I am new to VEX IQ, so any tips and tricks with troubleshooting these issues would help me greatly.IMG_7234

Thank you

Make sure latest VEXos
& look at VEX IQ brain stuck in DFU
& Cannot connect to Vex IQ Brain
And there is this VEX IQ Brain Problem which (like everything) may be out-of-date…
In Computer refusing to do anything with VEX IQ Brain there is discussion of COM ports which helped me with your first issue.
& Brains Not Communicating with Computers

I will quote myself (!):

Finally, especially about your second issue if not solved above:


Not a coder here, but I don’t think Vex Coding Studio works for Vex IQ. You have to use Robot C, Graphical Robot C, or Modkit.


Huh. Missed that. Well, OP had 2 issues.

Of course can use:

Robot Mesh




1 Like