Invalid Asset Table

I was updating the firmware for the Brain from 1.0.0 to 1.0.1, then it deleted the asset table and displayed that the asset table was going to be downloaded again. The update bar on VCS stopped progressing and the screen of the Brain turned black and flashed on for a moment displaying at the top in a red bar “Invalid Asset Table Version”. the screen now only displays four buttons one to restart the brain, a second that displays an SD card that asks you to power-cycle the brain, the third that deletes all installed programs, and a power off button. After I power-cycled the brain on VCS it says that the firmware is updated but the Brain doesn’t have an asset table and cannot run code or function as it should, I also haven’t been able to find anything on to solve this issue.

Ok, we just need to perform the update to 1.0.1 again, unfortunately this version of VCS does not have that ability, I will post a link to a stand alone updater with instructions a little later.

Sent private message

1 Like

I am also getting and “Invalid Asset Table Version!” Error. Nothing else on the screen, just a red bar along the top that says “Invalid Asset Table Version!”

We have not used any VCS so far, only RobotMesh. Didn’t think I did any firmware updates yet.

I sent you a PM

1 Like

please send me too! I am stuck with this issue as well. Tried to update firmware and got the error with 4 buttons that Whalez described. eventually i gave up and disconnected the brain from the computer. ever since then the brain has also been unresponsive although it is connected to a battery.

I also need a link to a standalone updater i am having the same problem of “Invalid Asset Table Version!” and cant find any information on what else to do. @jpearman

We have added the most recent version of the stand alone V5 Utility to the Firmware page on the website:

We will keep that link up to date as new releases are built.

1 Like

My team is all so having this issue.

Please, follow instructions from this topic:

Thank you this link worked.