V5 Brain's Micro USB Port

Problem:

I believe that my Micro USB port for my brain is dead.

This is a known problem with the brain and it has happened to lots of people.




etc

Debugging:

I’m using pros and I got this error message over and over w/o stop.

https://pastebin.com/Ugth9h2M

While I was getting those messages I was doing the following:

  • the brain was turned on
  • i replaced the usb cable through several working ones
  • changed the usb port on my computer
  • tried my controller
  • I restarted the brain
  • I tried to move the micro usb port connection to get a better connection
  • tried a different computer
  • tried rms

AKA I tried everything

idk what happened. I hope it’s not totally dead

it was being finicky yesterday but ended up working after a couple tries

Solution

Permament

I’m sure that the people who designed the brain could do one of the following:

  • support the micro usb port better
  • use a better connector like usb-c for the brain
Temporary

I would much appreciate it if I could get a replacement brain.

If you do end up trying to test a new usb port for the brain. I would be happy to do some testing for it.

– Michael Jones, Team 914M’s Head Programmer

1 Like

This probably falls in between permanent (proper) and temporary solutions.

Get a magnetic Micro-USB cable/adapter and leave it permanently installed in your new Brain.

That way you will put much less stress on the port and are much less likely to damage it.

(But you probably already knew this from the various threads you have clearly looked at)

3 Likes

@Barin I would do this, except:

  • It will not help due to it already being broken.

What you suggest is a solution to temporarily preventing the problem, however if problem has already happened, then it won’t fix anything.

2 Likes

If you contact VEX I’m sure they’ll see you right. Then use a magnetic cable on the new one.

1 Like

Also, if you use PROS, turn on hot/cold linking to upload via the controller instead. Upload a project to the brain for big changes but if it is minuscule (ex when testing auton) just do it via the controller to again avoid stressing the port.

1 Like

It seems that Vex needs to improve it’s quality control since it seems that almost every hardware related topic is about broken parts.

1 Like

The v5 is pretty janky tbh, it likes to break down randomly.
I hope vex figures out a v5 improvement pretty soon

1 Like

For my team, we’re planning to use magnetic usb attachments for the port once they arrive, but unfortnatly I don’t think Vex is going to change to USB C or anything. With my port it’s already seeming degrade, and difficult to plug into.

But that’s inevitable, no one ever posts that their hardware is not broken. I also don’t think for the most part it’s a QC issue, all this hardware gets treated pretty roughly by the end user, some of it will get broken. With cortex, it was usually blown motor ports due to shorted motor wires and things like that.

7 Likes

But what I’ve found with Ev3(lego) is that it didn’t break down so often as Vex.

Keep in mind ev3 is a different system, so it’s probably made differently. Also what @jpearman said.

1 Like

I don’t recommend using a magnetic connector.
They pick up metal shavings and short everything.
If you want a usb attachment (which is a good idea), I recommend a simple usb connector:

7 Likes

My team has a micro-USB to USB extension so that we can plug a cable directly into the USB instead of puling out and putting in a cable to the micro-USB. We just keep it plugged in at all times and it is covered by a little C channel to keep it from moving.

1 Like

We used a magnetic connector and always left the micro-USB end in the controller. One time I tried to pull it out and the connections came off and got stuck inside.

I have 8 V5 brains that are broken. That micro USB port keeps breaking off. My school has had these for 9 months and we are being charged $80 per unit to be fixed. I guess they are not made for school use.

1 Like

yep, 2 of mine have sanpped.

Please do not revive three year old topics. More so since the work around solution has been in place.

4 Likes

How was this thread not locked? I’m somewhat confused. I thought there was a script that auto-locked all year old threads.

1 Like

Hey, there is no “fix” other than having VEX repair them.

But ongoing it’s suggested that you do a USB adapter that is fastened to the robot. We do use the mag adapters, but our RULE is to “Never cut metal near the robot brain” to keep swarf out of all the ports.

Good luck!

4 Likes