Vex pro on parallels

Hello, whenever I run vexcode pro on parallels on my mac, I cannot transfer the code to the brain. THe status bar just goes to 5% and gives me a download error. I know for a fact that the problem isn’t the code that I have because the same exact thing worked on a different computer.

This Is what the console says when I press the transfer button.

[info]: Saving Project …
[info]: Project saved!
windows build for platform vexv5
make: Nothing to be done for ‘all’.
[info]: build completed!
[info]: download
[error]: download error!

Does the VM (Windows, I presume) show that the brain/controller is connected?

Have you told Parallels to pass the USB connection to the brain/controller through to the virtual machine?

1 Like

VEXcode Pro V5 exists for Mac as a native build - why use Parallels? This is not a tested nor officially supported use case.

https://www.vexrobotics.com/vexcode-download

I would imagine the answer to that is that the native build crashes on startup for @EliteBabby.

2 Likes

Got it… didn’t realize it was the same post.

Still - any future danger seekers - use the native builds :slight_smile:

1 Like

Yes. I told parallels to pass the connection to the virtual machine. On vexcode pro, the controller lit up green and everything seemed normal until I started transferring the program.