Glitchy gyro sensors

I’m building programs in VEXCode Blocks IQ that using the drivetrain with gyro sensor. Occasionally, when I run the program the gyro is not detecting turns accurately. For example, the robot might turn 90 degrees, but the sensor is showing only a few degrees. This happens even if I turn off the program and check the sensor in the brain settings. I can usually fix it by either turning the brain off and back on, or by disconnecting the cable from either the sensor or the brain, or both, and reconnecting it. No fix works every time. I’ve experienced this with two brand new gyros, using different wires. The drivetrain is 1:1 so that’s not the issue. I think it’s either sketchy hardware or glitchy firmware. I don’t think it’s calibration because the problem occurs with or without calibration. Has anyone else experienced this problem and nailed down what the issue is?

Is this the legacy gyro sensors (with the 3 pin wires), or the new V5 inertial sensor? I’ve heard that the legacy gyro sensors had a lot of drift, which makes it a lot more inaccurate. Some things teams have done to fix what was mentioned is mounting it on rubber links.
Another issue potentially is you might not be adding delays corrently in your program possibly? This causes inconsistencies as well.
Finally, for us, our inertial sensor was not accurate at first. But then that was fixed by calibrating it repeatedly.

1 Like

The post is in the IQ category, and:

I don’t think @robokai is talking about the VRC gyro sensors.

This may be of some help:

1 Like

Once again, @robokai does not need help with the V5 sensors.

I am not entirely sure of your problem, but this video may be of some help.


Sorry, I didn’t pay attention to the IQ bit, assuming it was miscategorized, because it mentioned brain.

Have you looked at older topics about IQ gyro problems? Did you see anything there?

Also, you say you tried two different gyros and different cables. Did you try to plugin into different ports? Could the port be bad and gyro losing connection as robot moves?

What is the firmware version and what are the other plugged sensors? Could they be interfering in some way?

I am not experienced with IQ system, but @jpearman would be able to give some advice, if you provide additional information about your system setup and attach the source code.

1 Like