In a game and the game ends the motors release and it doesn't keep a fixed position

When I’m in a game and the game ends the motors release and it doesn’t keep a fixed position. So when the program ends the motor doesn’t keep a fixed position. So after the game ends the motor moves and releases the goal that’s clamped. Does any of you know why this is happening and how to fix it?

Rubber bands support. Make the motor slightly fight to stay down to pick up the goal. So after picking up the goal the motor is able to be turned off and the goal stays.


I heard this a programming issue and I don’t know how to have when the program end it doesn’t move the motor. Everyone else in my club doesn’t have there’s work and they said its a programming issue. They don’t have rubber bands on their clamp that clamps the goal.

I don’t think it’s a programming issue. Correct me if I’m wrong, but I believe that motor braking gets automatically disabled when auton ends. As @Connor said, the best way to fix this is with rubber bands.


It’s not, vexos will place all motors in coast mode when a program is disabled.


So we can conclude that this is a cause of a hardware problem?

Perhaps a robot design problem would be more accurate.

V5 motors have all power removed when the robot is disabled or the program is stopped, this behavior matches the older cortex system and is done for safety reasons.


I think it’s just because when the match ends so does the program.

Some ways to fix this might be something to counteract the gravitational pull (for example compound gearing and/or rubber bands) but you might encounter other problems with those.

Hope this helps, good luck!

if you make the gear ratio high torque or use a worm gear, that can help to hold it better.

Set the goal down, don’t leave it clamped.

While you need to be able to release the goal without power, I have seen some times where the goal falling down tips the platform, so it is nice to be able to keep it up (but without requiring power to release)

1 Like

When you program it the computer’s default setting to stop the catapult is COAST but you need to change it to HOLD.

well no. first off, why are you talking about a catapult? second, they have a hold code, the code is cut off at the end of auton/the match

I thought they were taking about the catapult motor releases when they let go of the buttons when they are trying to hang that is how you fix it

The topic is tagged as Vexcode pro v5. I dont know much about iq, or if the motors are different, but in this case the problem is simply that hold brake command gets cut off at the end of a match

IQ has no field control, competitors just let go of the remotes when the match is over.

I see, makes sense that they would not encounter these problems then

Maybe it’s worth noting explicitly that holding is an active control process in the v5 system that logically must cease at match end. (Assuming I’ve got the right end of that stick.)

1 Like

It’s an active process inside the motor.

early versions of vexos would not change the motor mode, we made that change around 2 years ago at the request of the GDC so V5 would have the same behavior as the cortex.

(and an inspection requirement is the V5 must be running latest vexos, so rolling back to old version is not an option)


I’ve always wondered, how does one check that? Usually inspectors just ask and I point to my coder who says yes