V5 Brain "Invalid Asset Table Version"


#1

Brain boots up and gives the above message. (I attached a picture of the screen on boot up) Connecting it to VCS and it reads as if it is up to date for firmware. Is there any way to DFU the unit so that I can try to reload the firmware?
V5 screen.jpg


#2

I’ll send PM with instructions.


#3

My team is also receiving this same type of error. Could you please help by sending instructions?


#4

yes, sent PM, how and when did this happen ? During update from VCS ? or RobotMesh ? Were there any error messages saying to power cycle brain (or not power cycle brain) ?


#5

Thanks so much, however, now our brain isn’t turning on. Any thoughts on how to fix that?


#6

The brain also said to have a power cycle.


#7

Need some more details. Did the update happen successfully ? Did you use the utility I linked you to or RobotMesh ? Is the battery good ?


#8

No, the update did not happen. I tried to use the link you PM me with, but now the brain screen won’t even turn on or connect to the vex coding studio. Yes, the battery is good.


#9

Ok, if the V5 is not powering up, there’s really no way to troubleshoot. Give vex support a call.


#10

I have the same problem. This is after a session using @RobotMesh_Support . RobotMesh prompted me to update the firmware, and I allowed it, and an error was reported, but RobotMesh and the brain continued to work for the rest of that session. However, next time I powered up, I got the “invalid asset table version” error screen


#11

Ok, resolved my problem using the firmware updater utility


#12

@MattSnyder, thank you for the report. We’ll look into the error handling code.

When the asset table version is invalid, this can be solved by re-downloading the V5 firmware. Within a Robot Mesh Studio project, click on the Options (gear icon at the top-right) and choose Start firmware update…. Wait for both the BOOT firmware and the ASSET tables to download and restart the brain.

Or, use VEX’s firmware updater utility.


#13

jpearman, can you send me those instructions? I am having the same problem.


#14

Just grab the standalone V5 firmware updater from here, it will probably detect invalid assets and allow update.

If that doesn’t work, select the force update option after following the instructions below for showing the advanced options.
update_step_1.png

update_step_2.png


#15

@jpearman on help.vex.com there is an article posted 11/21 about using the standalone for Battery Medic and the screen shot indicated the firmware updater version 1.0.6 - do you know when it will be released?


#16

It was supposed to be up on the same day, fell through the cracks because of the holiday I suspect. It will be version 1.0.7 and should be available early next week. In addition to the battery diagnostics, it has some support for offline use, that is, once at least one update has been done it caches the latest vexos and will use that if it doesn’t have network access. It also collects additional system information to help with tech support, specifically the last 512 log entries.


#17

great - look forward to new diagnostics.

BTW kudos on the green radio LED for feedback that robot in connected to field and software running in competition mode - clear feedback for inspection and on the field that robot is ready (no guarantee that the team has the right V5 Controller in their hands… )