V5 Controller shows red screen and computer/brain icon


#1

Hi
First time VEX user here, just got the V5 brain, controller, motors etc.
They were with our SME first and he built a robot with them, then sent it to us. I don’t know if he powered it up/drove it around yet, and he is unavailable to me right now (the SME).
When powering up the controller it shows a red screen with an image of the controller connected to either a computer, or possibly the brain? Not sure. I’ve added an image.
I’ve been unable to callibrate the controller or to pair/sync it with the brain as it (the controller) is completely unresponsive and its screen will only show this image. I have reset the controller already (5+ second press with an allen wrench in the reset hole in the back) to no avail. Whenever it’s turned on the controller keeps showing this image.
What am I missing? I’ve had the controller connected to a micro-usb charger for over an hour how, so it shouldn’t be a battery issue…
20181014_130843.jpg


#2

I have not seen this - write to support@vex.com


#3

Somebody here suggested it might be a firmware issue. So I opened the VCS and performed a firmware update for the Brain. It froze halfway through the update (capture 1) and the brain showed a message saying “Invalid asset table version!” (capture 2) to which I have no idea what to do. I tried to press the reload/redo buttton to no avail.


#4

Similar Asset Tableissue

I would see if @jpearman can shed light.


#5

Our students briefly saw that red screen while updating the firmware yesterday.

They fixed it by turning the v5 controller off and on, then the Brain asked to perform the firmware update on the controller. Once the firmware update was done, everything was good.

Have you updated the firmware to version 1.0.2?


#6

For the original issue, red controller screen, connect the controller to the V5 brain using a smart cable and it should update or repair firmware as needed.

For bad asset table problems, I will send private messages with link to a utility that will reload firmware shortly.


#7

My students got the red screen on their controller today. They were using the netdot 2nd generation magnetic download cable that was recommended on the forum. When connecting the cable to the magnetic part sometimes the laptop will say “No V5 connected”. They would pull the cable off & try to reconnect & as this was occurring the controller went red w/ a message about losing the link. When they turned the controller off then back on it was still red so they tried to turn the V5 brain off but it was frozen & wouldn’t power off. Nothing on the touch screen worked. The light on the Wi Fi also had gone off. Finally had to unplug the battery, wait 10 secs then reboot. They tried to attach the download cable again & the same thing occurred. Noticed that the netdot cable is slightly wider than VEX’s download cable so the cable attaches a little crooked because the battery cable is in the way. They had been using it for the 1st time all day before the red screen occurred. What causes this to occur? Is there a better cable than the netdot 2nd generation magnetic cable? Or is there another issue here? Thank you.


#8

This means that the V5 brain is updated to a higher version than the Controller, in which the Controller needs to be updated as well. The red screen with that image means that you need to tether the V5 Controller to the V5 Brain. Just plug a V5 cable into any port on the V5 Brain and connect the other end of the V5 cable into one of the ports of the controller. It should then update the controller.


#9

Thanks Connor. The controller should be updated as it was updated the same time as the V5 brain (we started using them for the 1st time in late Dec) but will have the kids check it out on Tue.